Back to overview
Downtime

Lagstorm and Mail server is down.

Mar 11, 2026 at 6:52am UTC
Affected services
Mail Server
ping lagstorm.voidhosting.vip:8080

Resolved
Mar 12, 2026 at 5:16pm UTC

We have resolved the issue. Service should be back up.

Created
Mar 11, 2026 at 6:52am UTC

We have acknowledged the issue and are currently working on a fix.